情報科学屋さんを目指す人のメモ(FC2ブログ版)

何かのやり方や、問題の解決方法をどんどんメモするブログ。そんな大学院生の活動「キャッシュ」に誰かがヒットしてくれることを祈って。

ブログ内検索

スポンサーサイト このエントリーを含むはてなブックマーク

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

スポンサー広告 | 編集
このエントリーをはてなブックマークに追加 Clip to Evernote

YouTubeやニコ動の画面が緑になって見れない場合の対処法メモ このエントリーを含むはてなブックマーク

GreenFlash

YouTubeの映像が緑だけに

ふとYouTubeの動画を見ようと思って再生してみると、緑画面が表示されるだけで、音は聞こえるのに映像が緑だけで変化しないという状態に陥ってしまいました。発生したのはVista SP2 32bitです。また、緑色の線が入ることもあるようです。

ひょっとすると、YouTube以外でも、Flashを使って動画を再生していたら発生するかもしれません(ニコニコ動画など)。ちなみに、ブラウザによって問題が発生するしないに差がありました。問題が発生したのはOpera、Chrome、Safari、Firefoxです。発生しなかったのはIE8、Sleipnirです。

ちなみに、Adobe Flash Playerのバージョンは10,1,53,64です。→バージョンを確認する

対策

再起動すればどうせ治るだろうと思ったのですが、それで治ってしまったのではつまらないので、対策を取ってみました。

まず、YouTubeの動画を右クリックします。すると、表示されるメニューの中に「設定...」という項目が出てくるはずです。それをクリックします。

すると、「Adobe Flash Player 設定」が表示されます。「ディスプレイ」という項目(最初に表示される項目)に、「ハードウェアアクセラレーションを有効化」というチェックボックスがあると思います。おそらくそこがONになっていると思うので、それを「OFF」にします。

これで、対策は完了です、うまくいけば、ページをリロードすると緑色だった画面が無事通常の動画再生画面になっていると思います。

おわりに

最近Adobe Flash Playerをバージョンアップした気がするので、それが原因かもしれません。ただ、Adobeのせいではなく、こっちのグラフィックドライバのせいかもしれない気がとてもします。根本的に解決するためには、新しいグラフィックカードへの交換が必要なのかもしれません。

追記(2012.04.11)

この現象に遭遇する人がとても多いようなので、もしよろしければ、この問題が発生した環境(OS、ブラウザ、Flash Playerのバージョン」などをコメントにて報告していただければ幸いです。今後検索する方の参考になると思われます。

ウェブサービス | コメント:52 | トラックバック:0 | 編集
このエントリーをはてなブックマークに追加 Clip to Evernote

この記事のコメント

昔POWERDVDとかのプレイヤーでグラボの再生支援機能を使ったとき出ていた記憶があります…
あ、うちのグラボは対応してないんだ…と簡単に割り切ってました。
恐らく同じ感じなのではないだろうか…と感じますが
いかがでしょうか。
2010-06-25 Fri 19:11 |  笑い男 [ 編集]
> 笑い男さん
コメントありがとうございます。

緑のみの画面になるのは再生支援(ハードウェアアクセラレーション)がうまく動作していない場合であることが多いようです。なので、今回ハードウェアアクセラレーションをOFFにしたのは、問題を回避するためには一番素直で手っ取り早い方法かと思います。

ただ、IE8ではONのまま再生できていたので、IE8経由(?)ならアクセラレーションが正しく動くのか、はたまたIE8がそもそもアクセラレーションに対応しておらずにONでもOFFでも変わらないようになっているのかが気になります。
2010-06-26 Sat 11:10 |  did2
ありがとうございました!
2011-02-23 Wed 21:01 |  Anonymous Coward
コメントありがとうございます。

> ありがとうございました!
どういたしまして!^^
2011-02-23 Wed 22:19 |  did2
参考にさせていただきました。
無事直りました。
ありがとうございました。
2011-03-26 Sat 12:57 | 
コメントありがとうございます

> 無事直りました。
お役に立てて嬉しいです!
2011-03-26 Sat 22:08 |  did2
無事になおりました
ありがとうございます。

私も最近バージョンアップしてからこの状況でしたので原因はそれでしょうか?
2011-03-29 Tue 21:54 |  抹茶
> 抹茶さん
コメントありがとうございます

> 私も最近バージョンアップしてからこの状況でしたので原因はそれでしょうか?
やはりバージョンアップしたせいですかね。それが原因で、どこかと(たぶんグラフィックドライバ)相性が悪くなってしまったのかもしれません。逆に考えると、またバージョンが上がれば直っているかもしれませんね。
2011-03-29 Tue 23:52 |  did2
ありがとうございます。
ハードウェアアクセラレーション OFF で解決しました_〆(。。)メモメモ…
2011-08-14 Sun 22:46 |  つぐ
> つぐさん
コメントありがとうございます。

> ハードウェアアクセラレーション OFF で解決しました_〆(。。)メモメモ…
分かってしまえば簡単ですよね。報告ありがとうございました。
2011-08-14 Sun 23:45 |  did2
とても参考になりました、ありがとうございます。
ただ、この問題当方の環境では、再起動しても治りませんでした。
発生原因は恐らく、adobe flash playerのアップデートでしょう。私もアップデートごにこの問題が発生したのでw
2012-04-05 Thu 02:33 |  EViL
> EViL さん
コメントありがとうございます。

再起動では直らなかったようですが、うまくアクセラレーションをOFFにすることで症状は改善できましたでしょうか?

ここのところこのページへのアクセスが増えているようなので、やはりアップデートがきっかけになったことで、たくさんのユーザさんの環境で同時に問題が発生しているのかもしれません。
2012-04-05 Thu 17:56 |  did2
ありがとうございました

「ハードウェアアクセラレーションをOFF」で動画がみれるようになりました

よく考えると、わたしもadobe flash playerアップデート後にこの現象になったような気が…

わかりやすい説明にてThx!
2012-04-09 Mon 18:09 |  [ 編集]
やはりアップデートが原因かもしれませんね。報告ありがとうございます!
2012-04-11 Wed 00:37 |  did2
こちらを参考にアクセラレーションをOFFにすることで緑画面を元に戻すことに成功しました。

発生当時の環境は

windows 7 Professional
ServicePack1
64bit版

ブラウザは
Internet Explorer 9

Flash Playerのバージョンは
11,2,202,228

です。
友人にもらったPCなので詳しくはわからないのですが、これでお役に立てれば幸いです。
長々と失礼しました。
2012-04-13 Fri 01:29 |  蓮 [ 編集]
> 蓮さん
IEでも緑色になるんですね。報告ありがとうございました!
2012-04-13 Fri 11:57 |  did2
今日気が付きました。
Windows 7 Pro 64bit SP1
Radeon HD4290(内蔵)+Catalyst12.3
Flash Player 11,2,202,233
Firefox 11.0
Chrome 18.0.1025.162 m

Catalyst側の設定で躱せないかと思いましたが、試した限りではダメでした。
2012-04-15 Sun 00:45 |  LD
スペック
http://www.negitaku.org/members/13578/
Flash ver 11,2,202,233 installed

firefox sleipnir sleipnir ユニコーンの奴

私はこの3個のブラウザでなりました

ハードウェアアクセラレーションを有効化
offで解決しました!友人に何回もOS入れなおしてる奴がいるので速攻で教えてあげようと思いますw
2012-04-15 Sun 09:03 |  崩壊 [ 編集]
まさに症状が検索していたらここにたどり着いて主さんのとおりにやると改善されました!
ありがとうございます!

Win7 Pro 64bit
firefox ポータブル 3.6.2.8
2012-04-16 Mon 00:18 | 
> LDさん

コメントありがとうございます。

ドライバ(Catalyst)のバージョンやグラフィックボードの品番も関係しているかもしれませんね。Catalyst側の設定でも駄目でしたか。詳細な報告ありがとうございました!
2012-04-16 Mon 14:11 |  did2
> 崩壊さん
コメントありがとうございます。

参考のために(関係の深そうな)VGAをリンク先よりコピーさせてください→「VGA:MSI GeForce GTX 560 Ti HAWK」。また、複数ブラウザでの報告ありがとうございます。

それにしてもOS入れ直しとはw 早くその友人に教えてあげてくださいw
2012-04-16 Mon 14:22 |  did2
> 2012-04-16 Mon 00:18の名無しさん
コメント&報告ありがとうございました!
2012-04-16 Mon 14:26 |  did2
コンピューターに詳しくないので、とてもビビリましたが、ハードウェアアクセラレーションを有効化を「OFF」で無事直りました。

ありがとうございます。

症状:画面上部に緑の線、その下の画面は全体的に赤みがかる。音は正常。

windows 7 Home Premium
Internet Explorer 9
Adobe Flash Player 11.2.202.235
2012-05-16 Wed 01:36 |  MACHI
このコメントは管理者の承認待ちです
2012-05-21 Mon 00:40 | 
> MACHIさん
コメント通知のメールが受け取れず、返信が遅くなってしまいました。申し訳ありません。

緑色の画面は、自分が見ても不気味でした。やはりハードウェアアクセラレーションが原因でしたか。
全体的に赤みがかかるという症状は初耳です。情報ありがとうございます!
2012-05-28 Mon 17:13 |  did2
> m(_ _)m さん
返信が遅れてしまい申し訳ありません。

緑のままだった、というのは、ハードウェアアクセラレーションをOFFにしても、ということでしょうか。

それはともかく、このページが役に立ったようで良かったです。
わざわざコメント&報告ありがとうございました!
2012-05-28 Mon 17:15 |  did2
こんにちわ。
私は
win7x64でIE9。
Geforce570 (285.62)と
flash11.2.202.235で起きました。

その後、グラフィックのドライバ(301.42)を更新してこの症状が治りました。
ですから、グラフィックカード自体やそれぞれの問題ではなく
ドライバとflashの相性の問題ですね。
2012-06-05 Tue 14:00 |  mith
ありがとうございますありがとうございます!
おかげで治りましたー。

OS: Win7 Home Premium 64bit
ブラウザ: Sleipnir3 ver.3.5.0.4000
Flash Player: 11.3.300.257
2012-07-08 Sun 02:32 | 
初めまして。
このサイトを見てお願いっしたいことがあります!
動画サイトの画面が緑になるまでは同じなのですが、PC動画も見れなくなっているのです・・・
※音声は出ます。
adobe flashも最新版にしていますし、media playerも最新版、他のプレイヤーでもダメ・・・再起動でもダメ・・・
どうしようもないのです。
どうかこれを直す方法を知っていましたら教えてください○┓ペコリ
2012-07-25 Wed 11:40 |  桜の木
この状態になってしまい困っていたところを、
検索でここに辿り着き解決しました。
ありがとうございました。

IE9 WINDOWS7 64BIT
2012-07-26 Thu 08:24 | 
こんにちは。
私は、ニコニコ動画でなりました。
[ハードウェアアクセラレーションをOFF]してから、再起動したら直りました。
ありがとうございました。

OS: Windows XP professional
ブラウザ:IE8
Flash Player:11,3,300,271
2012-08-23 Thu 12:08 |  ピリッと [ 編集]
こんにちは。
ニコニコ動画で発生しました。

ハードウェアアクセラレーションOFF実施、再起動しても直りませんでした。

環境は
Windows7home premium 64bit
IE9
Flash Playerが32bit版になっていたので、64bitの最新にしましたが、変わらず。

ブラウザはSleipnirを使っていました。(IEの設定を引っ張ってる?)
一時ファイルなどの不要データを削除しましたが、変わらず。
ブラウザの問題かと思い、Google Chromeに変更してみたところ、Sleipnirほどではなくなったという程度の状況でした。
グラボ新調するにもGTX480 x2基なので、新しいのを買うのは難しいです・・・w
2012-09-13 Thu 18:04 |  かご
今まで普通に見れていたニコニコ動画で、ある日突然緑画面になり見れなくなりました。

いろいろやって解決したので参考になれば。
MTUとRWINの値を、わざと少なめに設定すると緑画面が出なくなりました。
2012-09-14 Fri 17:17 | 
環境を書いていませんでしたね。
Windows7 Professional 64bit
InternetExplorer 9 32bit
Adobe Flash 11.4.402.265 32bit
2012-09-14 Fri 17:22 | 
私のPCでは画面が全体的に緑でモザイクがかかったような状態でした。
再起動しても改善されなかったため、改善方法を探してみたところこの記事を見つけることができました。
ちなみにIEでは問題なく動画が見れました。

[ハードウェアアクセラレーションをOFF]を実施し、ページを更新することで改善できました。

環境は
OS:Windows7 home premium 64bit
ブラウザ:chrome ver:15.0.874.120 m
adobe:ver:11,1,102,55

この記事のおかげでchromeで動画が見れるようになりました。ありがとうございました。
2012-10-22 Mon 18:28 |  ねこ [ 編集]
最近頻繁にプレイヤーがクラッシュしたり緑色になったりしていて、色々ぐぐった結果こちらに辿りつき、おかげさまで直りました。

ブラウザ:IE9 firefox
OS:Windows7 home premium 64bit
グラボ:HD5850 catalyst12.6
Flash Player:11,4,402,287
2012-10-24 Wed 20:04 |  桃太郎侍
このコメントは管理者の承認待ちです
2012-12-17 Mon 01:36 | 
このコメントは管理者の承認待ちです
2012-12-18 Tue 04:29 | 
このコメントは管理者の承認待ちです
2012-12-20 Thu 11:19 | 
このコメントは管理者の承認待ちです
2012-12-21 Fri 08:32 | 
このコメントは管理者の承認待ちです
2012-12-26 Wed 11:17 | 
自分は逆にONにしたら緑になる現象が直りました
Microsoft Windows XP
Professional
Service Pack 3

Pentium(R) 4 CPU 3.00GHz
2.99 GHz,3.11 GB RAM

使用ブラウザ firefox 19.0.2
adobe 11.6.602.180
2013-03-14 Thu 14:57 | 
このコメントは管理者の承認待ちです
2013-04-05 Fri 11:45 | 
このコメントは管理者の承認待ちです
2013-05-06 Mon 23:19 | 
こんにちは。

ニコニコ動画視聴中、突然の機械音と緑の画面に驚いて調べてみたところ、こちらのページのおかげで解決しました!
ありがとうございました。

環境は
OS:Windows 7 Home Premidium
ブラウザ:Internet Explorer
Flash Player:11,7,700,202
2013-05-29 Wed 12:29 |  由貴
設定という項目がないんですけど・・・。

どうしたら直りますかねw
2013-08-16 Fri 12:21 |  まな [ 編集]
ONにしたら直りました

Windows 7 Home Premidium
Google Chrome ver.28.0.1500.95 m
Adobe Flash Player ver.11.8.800.97
2013-08-18 Sun 17:09 | 
このコメントは管理者の承認待ちです
2013-09-21 Sat 22:04 | 
このコメントは管理者の承認待ちです
2013-10-12 Sat 13:51 | 
このコメントは管理者の承認待ちです
2014-02-13 Thu 15:50 | 
このコメントは管理者の承認待ちです
2015-08-09 Sun 23:58 | 
このコメントは管理者の承認待ちです
2017-09-30 Sat 21:16 | 

コメントの投稿 エントリの新旧に関わらず、極力18時間中に返信します。














この記事のトラックバック

トラックバックURL:
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。